Upgrade from WPtouch Pro 3.x to WPtouch Pro 4.x fails

When upgrading from WPtouch Pro 3.x to 4.x, the plugin will rename the plugin's folder from wptouch-pro-3 to wptouch-pro. When WPtouch Pro is not able to rename the folder, the automatic update will fail and you will see the following message:


The issue usually occurs when WPtouch Pro can't write to the /wp-content/plugins directory because directory permissions are too restrictive. You may try remedying the issue by changing the directory/file permissions for /wp-content/plugins/wptouch-pro-3 and /wp-content/plugins/wptouch-pro-3/wptouch-pro-3.php to 755 and only go more relaxed if needed.


If you are not familiar with changing directory permissions, please contact your web host and they should be able to assist you. If you you are not able to change directory permissions or if the update continues to fail, you can delete version 3.9 via the Plugins page in WordPress (your settings will remain safe). Then, download the 4.x version from https://www.wptouch.com/account. Upload the zip file via Plugins > Add New > Upload and click to Activate the plugin.


If you continue to experience issues upgrading to WPtouch Pro 4.x, do not hesitate to contact our support team at https://support.wptouch.com/helpdesk/tickets

Still need help? Contact Us Contact Us